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Flash has a reputation as a powerful and robust animation tool. If you

know other animation tools, such as Adobe After Effects or Adobe

Director, you might be looking for similarities. It’s actually easier to learn

the animation capabilities of Adobe Flash CS3 Professional if you don’t

know other animation programs, because you’ll have no preconceived

notions of how you think it might work.

This chapter introduces you to the Timeline, which plays a significant

role in producing animations. The Timeline lets you work with keyframes,

blank keyframes, frame-by-frame animation, and onion skinning. If these

are new terms to you, they won’t be for long. This chapter also covers

setting the frame rate (and how it affects playback speeds). By the end of

this chapter, things should really get moving for you, all puns intended!
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Understanding and working with the Timeline is essential to creating animations in Flash CS3. The 
illustration shown here identifies the elements of the Timeline you’ll be working with in this chapter.

The following chart describes the Timeline features:

The following chart describes the Timeline features:

67Chapter 4 : Animating in Flash

Understanding the Timeline

Timeline Features

Feature Description

Frame Represents a unit of time in an animation. Just like film, Flash CS3 divides lengths
of time into frames. Frames with no content are represented by white squares.
Frames with content are shaded. Frames carry the content of the previous
keyframe.The frame rate determines how much time each frame takes up. For
example, if your movie’s frame rate is 12 fps (frame per second), one frame 
will take up 1/12 of 1 second. If an object is on the Stage for 24 frames, it will
appear visible for 2 seconds in the movie. You’ll learn more about frame rates
later in this chapter.

Keyframe Defines a moment on the Timeline when content is inserted or actions or anima-
tion changes occur. A keyframe with content is represented by a solid dot; a
blank keyframe is represented by an empty dot. See the Working with Frames
and Keyframes chart following Exercise 1  for more information on keyframes.

Playhead Indicates the currently selected keyframe. Drag (or scrub) the playhead, which 
is the red rectangle with the long red line, back and forth on the Timeline to
quickly preview your animation.

continues on next page

Playhead FramesLayer stack Keyframe Options menu

Indicators:
Current Frame, Frame Rate, and Elapsed Time
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Timeline Features continued

Feature Description

Options menu Gives you several options for changing the size and therefore the number of
frames visible at one time on the Timeline. The default view, Normal, displays
the frames at an appropriate size for most projects. However, when you start
creating longer animations, you will need to set the Frame view to Small or
Tiny so you can see more frames at one time. You can also use the Placement
options to dictate whether the Timeline appears above, below, left, or right 
of the document.

Layer stack Organizes the elements of an animation and controls the order in which they
stack on top of each other. In Flash, you can animate layers independently. 
Each layer has options for hiding or showing the layer, locking it, and displaying
its contents as outlines. Immediately below the layer stack are buttons to insert
a new layer, add a layer folder, and delete a layer. You’ll learn more about layers
in Chapter 5, “Shape Tweening.”

Current Frame Displays the current position of the playhead and the frame number of the 
currently selected frame.

Frame Rate Displays the number of frames per second at which the movie attempts to play
on the user’s browser or computer. Double-clicking the frame rate value is a
quick way to access the Document Properties dialog box.

Elapsed Time Displays the time elapsed (at the selected frame rate) from Frame 1 to the 
current playhead location.
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E X E R C I S E

Setting Document Properties

The document properties are general specifications—such as Stage dimensions, background color, and
frame rate—that affect your entire project. When you start a new project in Flash CS3, you should set the
document properties. This exercise shows you how.

Copy the chap_04 folder from the Flash HOT CD-ROM to your desktop. Open a new file by choos-
ing File > New > Flash File (ActionScript 3.0). Choose File > Save.

In the Save dialog box, name the file movie.fla, and save it in the chap_04 folder. Make sure the
Property inspector is visible. If it’s not, choose Window > Properties > Properties.

Notice the following default document properties: the default Stage dimensions are 550 x 400 pixels, 
the default movie background is white, and the default frame rate is 12 frames per second. You’ll learn
how to change each setting in the following steps. Document class is empty by default; you’ll learn 
more about this document property in Chapter 12, “ActionScript Basics.”

In the Property inspector, type 24 in the Frame rate field.

For every second of your animation, 24 frames will play. You’ll learn more about frame rates in the 
next exercise.

In the Property inspector, click the Background color box to display the default color palette.
Select a light blue to change the background color of your movie.

In the Property inspector, click the Size button to open the Document Properties dialog box.

In the Document Properties dialog box, you can enter a title and brief description of your movie, as well
as set frame rate preferences, movie dimensions, background color, and rule measurements for your
entire movie.

5
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Type 700 in the width field and 350 in the height field.

These fields control the absolute pixel dimensions of the
Stage. You will learn other ways to control the size of your
movie in Chapter 17, “Publishing and Exporting.”

Click the Ruler units pop-up menu, which contains 
several ways to display the ruler units on your Stage. 
Leave this option set to the default—Pixels.

Click OK to close the Document Properties dialog box.

Notice the values in the Property inspector—the dimensions, background color, and frame rate have
changed to reflect the settings you specified in the Document Properties dialog box.

You can quickly use the Property inspector at any point to change the movie’s background color or frame
rate. In addition, you can use the Size button to access the Document Properties dialog box, where you
can change the Stage dimensions and ruler units. However, avoid changing dimensions once you have
started adding content to your Stage. Changing Stage dimensions at this point offsets the position of
your artwork, which can be difficult to fix.

8

7

6
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Save your changes, and leave movie.fla open for the next exercise.9

71Chapter 4 : Animating in Flash

T I P : Changing the Default Document Properties
When you create a new movie, the default
Stage size is 550 x 400 pixels with a white
background and a frame rate of 12 fps.
These settings may not be appropriate for
most of your projects. But there’s good
news—you can quickly redefine the default
settings so they better fit your needs.
Simply change the document properties 
to match the settings you need, and click
the Make Default button (as shown in the
illustration here). The next time you create
a new movie, it will already have all the
properties you specified. Pretty cool!

Before you start creating animations, you need a
better understanding of two terms—frames and
keyframes. As mentioned previously, in Flash CS3,
the Timeline represents the passing of time, 
with each slot on the Timeline representing an
individual frame. Keyframes are a special type 
of frame that represent a change in the content 
of your movie.

When you open a new document, Flash always
inserts a blank keyframe at Frame 1. If you add
artwork to Frame 1 and insert 20 new regular
frames, the image on Frame 1 will persist until the
last frame (Frame 21). To change the appearance
of an animation, you must add new keyframes. 
If you want to change your artwork on Frame 2,

you first insert a new keyframe on Frame 2 and
then make the change on the Stage. Again, a
keyframe will indicate a change in content
between two frames.

If you’ve never worked with animation before,
these concepts may seem foreign to you. Not to
worry, you’ll have lots of opportunities to work
with frames and keyframes in this chapter.

Before you start the rest of the hands-on exer-
cises, you need to identify and create frames and
keyframes on the Timeline. The following chart
describes each in more detail, including keyboard
shortcuts where available:

Understanding Keyframes and Frames
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Frames and Keyframes

Feature Description

Frame Although the Timeline in Flash CS3 has slots for frames, you have to define
them as frames or keyframes in order for the content to exist at that point in
the movie. Different layers can have different numbers of frames. For exam-
ple, Layer 1 could have ten frames while Layer 2 has only one. There cannot
be gaps between frames; when you insert a frame, all of the previous slots
are also defined as frames. If you insert frames between keyframes, you will
lengthen the time of your animation without affecting the contents. To insert
frames, select any slot(s) or existing frame(s) on the Timeline and press F5, or
choose Insert > Timeline > Frame.

Keyframe A keyframe indicates a change in content or motion between frames. A
keyframe containing artwork is represented by a solid black circle. By default,
when you add a new keyframe in Flash CS3, the content (except for actions
and sounds) is copied from the previous keyframe. Adding a keyframe will
not, by itself, change the artwork. To insert a new keyframe, select any slot or
frame on the Timeline to select it, and then press F6 or choose Insert >
Timeline > Keyframe. (Note: A keyframe will be added if you have artwork in
a previous frame or keyframe. If the previous frame is blank, pressing F6 will
add only a blank keyframe.)

Blank keyframe A blank keyframe is a keyframe without any artwork. By default, when you
create a new document, the Timeline contains one blank keyframe, which
you can identify by the empty circle icon. (As soon as you create or place art-
work on the Stage, it becomes a regular keyframe, and the empty circle icon
changes to a solid black circle.) A blank keyframe can contain actions and
sounds. You will learn more about sound in Chapter 14, “Sound,” and more
about actions in Chapter 12, “ActionScript Basics.” Inserting a blank keyframe
on the Timeline will remove any content, including actions and sounds, in that
layer from the Stage at that point. To insert a blank keyframe, select any slot
or frame on the Timeline, and then press F7 or choose Insert > Timeline >
Blank Keyframe.

Clearing Clearing a frame removes the contents of the frame but leaves the frame 
frames itself. This process will not reduce the number of frames in a layer. To clear 

a frame or frames, select the frame(s), and then press Alt+Backspace
(Windows) or Opt+Delete (Mac) or choose Edit > Timeline > Clear Frames.

Clearing If you clear a keyframe, this process will simply convert a keyframe to a 
keyframes regular frame. Choose Edit > Timeline > Clear Frames, or press Shift+F6.

You can also clear a keyframe by right-clicking (Windows) or Ctrl-clicking
(Mac) a frame and choosing Clear Keyframe from the contextual menu.

Removing If you need to delete frames, keyframes, or blank keyframes, select the frames
frames on the Timeline, and then press Shift+F5 or choose Edit > Timeline > Remove

Frames. You can also remove frames by right-clicking (Windows) or Ctrl-
clicking (Mac) a frame and choosing Remove Frames from the contextual menu.
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E X E R C I S E Creating Frame-by-Frame Animations 

with Keyframes
A common animation technique is to make a word appear as though it is being written before your eyes.
You can achieve this effect easily using keyframes. When you insert a keyframe, Flash CS3 copies the
content of the previous keyframe to the newly created keyframe, which you can then change to create an
animation. In this exercise, you’ll learn how to make the word xboard! animate on the Stage using frame-
by-frame animation.

Open movieFinal.fla from the chap_04 folder.

The easiest way to understand animations is to look at a finished example, such as the one in movieFinal.fla.

Press Enter (Windows) or
Return (Mac) to preview the 
animation on the Stage.

Notice the animation creates the
word xboard! magically before
your eyes! Although it may seem
complicated, you’ll see how easy
it is to create a frame-by-frame
animation with keyframes in 
this exercise.

Close movieFinal.fla. If you completed Exercise 1,
movie.fla should still be open. If it’s not, complete
Exercise 1, and then return to this exercise.

Notice movie.fla contains a single layer with a single
blank keyframe. This is the minimum you need to
start drawing. This also happens to be the way all 
new documents appear by default in Flash.

3
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On the Timeline, double-click the Layer 1 name. When the bounding box appears, rename the layer
xboard!, and press Enter (Windows) or Return (Mac).

Naming layers keeps them recognizable and organized.

Select the Brush tool in the Tools panel. From the Color and Options sections of the Tools panel,
select any brush size, shape, and color (other than white—you’ll see why in Step 11).

The Brush tool paints only fills, not strokes, so you want to change the color in the Fill Color well.

In the next few steps, you’ll write the word xboard! one letter at a time in a series of keyframes.

With the Brush tool selected in the Tools panel and with Frame 1 selected on the Timeline, draw
the first part of the letter x on the left side on the Stage, as shown in the illustration here.

Notice Frame 1 now contains a small black dot, indicating it contains artwork. Frame 1 is now referred 
to as a keyframe, rather than a blank keyframe, because it is no longer empty.

6
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To make a change on the Timeline, you must place a keyframe where you want the change to occur.
Adding a new keyframe will copy all the content from the previous keyframe to the new keyframe. Now
that you have filled in the first keyframe of Layer 1, you’ll add another keyframe at Frame 2 so you can
draw the second frame of your animation.

On the Timeline, click Frame 2 to select it, and choose Insert > Timeline > Keyframe or press F6.

This adds a new keyframe at Frame 2. Notice the contents of Frame 1 are the same as the contents of
Frame 2. You’ll add artwork to Frame 2 in the next step.

Tip: In Windows, remember the F6 keyboard shortcut, because you will be using it often to insert
keyframes.

With the Brush tool still selected and with Frame 2 selected on the Timeline, draw the second part
of the x on the new keyframe.

Choose Insert > Timeline > Keyframe to add a new keyframe to the Timeline on Frame 3.

Notice Frame 3 has the same contents as Frame 2.

9
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With the Brush tool still selected and with Frame 3 selected on the Timeline, draw a b on the Stage.
Drag (scrub) the playhead back and forth on the Timeline to quickly preview the animation. You’ll see
the x and b being drawn directly on the Stage.

Choose Preview in Context
from the Options menu to 
display a thumbnail preview of 
the contents of each keyframe.

Viewing the Timeline with black
dots representing keyframes with
artwork might seem somewhat
abstract to you. The Options menu
has several options for displaying
the contents of your individual
frames on the Timeline.

You’ll find the Preview in Context view helpful when creating frame-by-frame animations.

Note: Do you remember when you chose a color for the brush in Step 5, and you were asked to choose
any color other than white? Now you can see why. If you had chosen white for the brush color, you would
not see the artwork in the Preview in Context view because the Timeline frames are also white.

With Frame 3 selected on the Timeline, choose Insert > Timeline > Keyframe to insert another
keyframe on Frame 4.

With the Brush tool still selected, draw an o on the Stage. As you draw, you’ll see the contents of
Frame 4 appear on the Timeline preview.

As you continue to draw the word xboard!, you don’t have to draw the whole letter in each keyframe.
Instead, you can draw part of the letter (just as you did with the x) in one keyframe, choose Insert >
Timeline > Keyframe to insert the next keyframe, and draw the remaining parts of the letter in that
keyframe to create a more realistic animation.

Using the techniques you learned in this exercise, use the Brush tool, and add new keyframes to 
finish drawing the word xboard!. When you are done, your Timeline should look like the one shown in
the illustration here.

14

13

12

11

10

76 Adobe Flash CS3 Professional : H•O•T

04_FlashCS3HOT_(66-95).qxd  08/08/2007  01:20 PM  Page 76



Scrub the playhead across the Timeline to preview the animation on the Stage.

Press Enter (Windows) or Return (Mac) to play the animation once.

Unlike scrubbing the playhead, when you press Enter (Windows) or Return (Mac) to preview the anima-
tion on the Stage, you see an accurate preview of the frame rate for the animation, which you set to 
24 fps in Exercise 1.

Choose Control > Loop Playback and press Enter (Windows) or Return (Mac) to repeat the anima-
tion continuously. Looping repeats the animation until you choose to stop it.

Notice how fast the animation plays. Next, you’ll learn how to slow down the animation by adjusting the
frame rate, which defines how many frames your animation plays per second. Because of varying proces-
sor speeds, you have no guarantee your movie will always play back at the specified frame rate on every
computer. Keep this in mind when you’re designing and testing animations. If possible, always test your
movies on a variety of computers with varying processor speeds so you can get an accurate idea of the
range of results your viewers will see.

Press Enter (Windows) or Return (Mac) to stop the animation.

Choose Normal in the Options menu to change the Timeline to Normal view so you see keyframes
on the Timeline instead of a preview of the artwork.

Make sure the Property inspector is visible. If it’s not, choose Window > Properties > Properties.

Click the Stage to show the document properties in the Property inspector. In the Frame rate field,
decrease the frame rate to 12. As you learned in Exercise 1, 12 fps is the default frame rate when you
create a new movie in Flash CS3.

Press Enter (Windows) or Return (Mac).

Notice the animation plays slower. The movie is taking twice as long to play the same number of frames.
The lower the frame rate, the slower the animation plays (and vice versa). Go ahead and experiment 
with other frame rates. When you’re finished experimenting, return the frame rate to its default setting 
of 12 frames per second so you’re ready for the next exercise.

Save your movie.fla file by choosing File > Save. Close the file.23
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What Is the Frame Rate?

Frame Rate

Number of Frames ÷ Frame Rate = Duration

24 frames ÷ 12 fps = 2 seconds

36 frames ÷ 12 fps = 3 seconds

48 frames ÷ 24 fps = 2 seconds

The frame rate determines the number of frames
your movie plays per second. This rate corresponds
directly to the length of time your animation takes
to play.

Here’s how to use the frame rate to calculate 
the playback time of your animation: Start with
the total number of frames on the Timeline and
divide it by the frame rate; the result is the num-
ber of seconds it will take to view your movie.

For example, if your Timeline has 36 frames and
your frame rate is set to 12 fps, your animation
will be 3 seconds. The following chart gives exam-
ples of how the frame rate affects the duration of
the animation. Next, you will learn how to create
more than one animation in the same movie and
have them play at different speeds.

When you set a frame rate in Flash CS3, you’re
setting the maximum frame rate for your movie,
or how quickly the movie “tries” to play. The
actual playback frame rate depends on several
factors, including the download speed and
processor speed of the computer used to view 
the movie. If the frame rate is set higher than the
computer can display, the movie will play as fast
as the computer’s processor will allow. If you set
the frame rate to 200 (which is really high), the
average computer will not be able to display the
movie at this rate. Also, frames with more objects,

colors, or transparency than others take more time
for the computer to render. Thus, the actual frame
rate can vary during playback because of the ren-
dering requirements from one frame to another.

Based on these factors, use a frame rate of at
least 12 fps and not more than 25 fps so the 
average computer can display your movie as you
intended. A frame rate of 15 to 20 fps, which is
similar to the 24 fps used in motion pictures,
works well most of the time.

Recommended Frame Rates
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E X E R C I S E

Inserting and Deleting Frames

As you learn to create animations, you’ll want to adjust the speed of your animations. In the previous
exercise, you learned how to adjust the frame rate to increase and decrease the speed of an animation.
But what do you do if you want only certain sections of your movie to play faster or slower than other
sections? In this exercise, you will learn how to insert and remove frames on the Timeline so different
sections of an animation play at different speeds, even though they all share the same frame rate.

Open frames.fla from the chap_04
folder.

As you can see, the file contains one
layer with a simple frame-by-frame ani-
mation using text. You’ll get a chance 
to work with text in Chapter 13,
“Working with Text.”

Press Enter (Windows) or Return (Mac) to preview the animation on the Stage.

As you can see, the animation plays so fast you almost lose the effect of the text appearing one letter at a
time. Adjusting the frame rate to slow down this animation will affect the entire movie, which could be prob-
lematic because you may want other sections of your movie to play at a different speed. For example, in this
project you may want the word snow to appear slowly and the word board to appear quickly. You can solve
this problem easily by inserting duplicate frames at strategic points to lengthen parts of the animation.

On the Timeline, click Frame 1 to
select it. Choose Insert > Timeline >
Frame (or press F5), which duplicates
the contents of Frame 1 and extends
the Timeline by one frame.

When you add a new frame, Flash CS3
creates a duplicate of the previous
frame. You aren’t going to change this
content; if you wanted to change the
duplicate content, a keyframe would
have been a better choice.
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With Frame 1 still selected on the Timeline, choose Insert > Timeline > Frame to insert another
frame. Each time you choose Insert > Timeline > Frame or press F5, you will insert one frame to extend
the Timeline.

4
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T I P : What Do Those Dots Mean?
As you start adding content to your project, you’ll notice different icons on the
Timeline. The black dots indicate keyframes with content. The light gray frames with-
out icons indicate frames (no change in content). For example, as shown in the illus-
tration here, Frame 2, Frame 3, and Frame 4 have the same content as Keyframe 1.
The white rectangle indicates the last frame in a frame range, which means the next
frame will be either a blank keyframe (empty) or a keyframe (with content). In this
example, the empty circle icon indicates a blank keyframe.

With Frame 1 still selected on
the Timeline, choose Insert >
Timeline > Frame, or press F5 nine
more times (giving you a total of
eleven additional frames between
the first two keyframes).

By adding more frames, you are
extending the distance between the
first two keyframes on the Timeline.
The additional frames slow down the
speed of the animation because the
content of Keyframe 1 will display for
a longer period of time.

Press Enter (Windows) or Return (Mac) to preview the animation on the Stage.

Notice the significant delay between the letters s and n—about one second—because 12 frames divided
by 12 fps equals 1 second. Even though you changed the delay between the letters s and n, you didn’t
affect the speed of the rest of the animation. As you can see, this is a great trick to use when you want to
play different sections of an animation at different speeds.

6
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On the Timeline, click Frame 13 to select it.

Frame 13 is the new location of the second keyframe. It was originally on Frame 2 before you added
more frames in Steps 3, 4, and 5.

Choose Insert > Timeline >
Frame or press F5 11 times to insert
11 frames on the Timeline.

Each added frame contains the same
content as Frame 13, creating another
pause between the letters n and o.

Using the techniques you learned in Steps 7 and 8, add frames between the letters o and w and
between the letters w and b.

Press Enter (Windows) or
Return (Mac) to preview the anima-
tion on the Stage.

Notice how much slower the word
snow animates compared to the
word board. As you can see from
this exercise, you can control the
timing of an animation without hav-
ing to adjust the frame rate of the
entire movie. Inserting frames slows
down specific sections in the anima-
tion. The inverse is also true—you
can speed up an animation by
deleting frames. You’ll learn how in 
the next few steps.
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On the Timeline, click Frame 2 to
select it. Right-click (Windows) or Ctrl-
click (Mac), and choose Remove
Frames from the contextual menu or
use the shortcut key Shift+F5 to
remove the currently selected frame.

As you can see, you shortened the
Timeline by one frame and decreased
the amount of time between the let-
ters s and n in your animation.

Click Frame 7 and drag through Frame 11 to multiple-select the frames.

With Frame 7 through Frame 11 selected, choose Edit > Timeline > Remove Frames (or use the
shortcut key Shift+F5) to remove the selected frames and shorten your Timeline by five frames.

Using the techniques you learned in
Steps 11, 12, and 13, reduce the number
of frames so there are only five frames
between the s, n, o, and w keyframes.

Press Enter (Windows) or Return (Mac) to preview your animation on the Stage.

As you can see, the word snow now plays faster than it did in Step 10 but still slower than the letters in
the word board. The animation plays at two speeds because you have more frames between the
keyframes in the word snow but fewer frames between the keyframes for the word board. Adding frames
is a great technique for speeding up or slowing down the timing of animations without changing the
frame rate of the entire movie.

Close frames.fla. You don’t need to save your changes.16
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E X E R C I S E

Copying and Reversing Frames

Creating a looping animation (one that repeats indefinitely) can be a lot of work if you have to draw each
frame over and over. In Flash CS3, you can copy, paste, and reverse a sequence of frames to create a
looping animation. You will learn how in this exercise.

Open loopingFinal.fla from the chap_04 folder.

Choose Control > Loop
Playback to set the playback
option to loop, which means it
repeats indefinitely. Press Enter
(Windows) or Return (Mac) to pre-
view the animation on the Stage.

This is the completed version of
the animation you’ll create in this
exercise. As you can see, the
snowboarder cruises down and up
the mountain slope over and over.
You will create this same anima-
tion technique without having to
draw all the frames again.

Choose Control > Loop Playback to stop the animation from looping. Press Enter (Windows) or
Return (Mac) to stop previewing the animation on the Stage. Close loopingFinal.fla.

Open looping.fla from the
chap_04 folder.

The file contains a single layer
named snowboarding, which con-
tains a sequence of 10 keyframes.
In each keyframe, the boarder is a
little further down the slope, cre-
ating the illusion that the boarder
is moving down the slope when
the sequence plays back.
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On the Timeline, click the 
snowboarding layer to select all 
the frames.

Selecting a layer on the Timeline is an 
easy way to multiple-select the frames 
on a layer. Next, you’ll make a copy of 
the selected frames.

Position your cursor over the selected
frames. Click and drag the frames to the 
right on the Timeline. Don’t release the 
mouse just yet!

As you click and drag the frames, a light 
gray outline indicates the selected frames 
and where they’ll be moved when you 
release the mouse.

Without releasing the mouse, hold down the Alt key (Windows) or the Opt key (Mac).

Notice the small plus sign appears to the right of the cursor indicating you will duplicate (or copy), 
not move (or cut), the frames when you release the mouse.

Release the mouse to create a copy of
the selected frames on Frame 11 through
Frame 20.

Press Enter (Windows) or Return (Mac) to preview the movie on the Stage.

Notice the animation does not look correct. The snowboarder reaches the bottom of the slope and
jumps back up to the top, which is not the same as the single fluid motion you saw in the finished 
animation. In traditional animation, you’d have to redraw all the frames in reverse order to achieve this
effect. Fortunately in Flash CS3, you can save yourself that manual process and simply duplicate and
reverse the existing frames in the animation. You’ll learn how in the next steps.
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Click Frame 11, and then Shift-click Frame 20 to select Frame 11 through Frame 20. Choose
Modify > Timeline > Reverse Frames.

You won’t see a change on the Timeline, but you will notice the change on the Stage when you test the movie.

Press Enter (Windows) or Return (Mac) to preview your animation on the Stage. As you can see, the
snowboarder races down the hill and goes back up the hill, as if you were rewinding the film to view an instant
replay. Nice! If you choose Control > Loop Playback, you can watch the animation preview loop endlessly.

Close looping.fla. You don’t need to save your changes.12
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5
E X E R C I S E

Using Onion Skinning

Now that you have created a couple of frame-by-frame animations, it’s a good time to learn a few new
tricks. First, you’ll learn how to use the onion skinning feature, which lets you to see a ghost image of the
previous frame so you can see where you want to place the artwork in relation to the previous frames.
You will also learn to use the Free Transform tool, which allows you to scale, rotate, skew, and distort
your artwork.

Open onionFinal.fla file from the chap_04 folder.

Choose Control > Loop Playback
to set the playback option to loop,
which means it will repeat indefinitely.
Press Enter (Windows) or Return (Mac)
to preview the animation on the Stage.

This is the completed version of the 
animation you’ll create in this exercise.
In this animation, you’ll see the snow-
boarder catching some air! You will 
create this same animation technique
without having to draw all the frames
again.

Choose Control > Loop Playback to stop the looping. Press Enter (Windows) or Return (Mac) 
to stop previewing the animation on the Stage. When you’re finished viewing the animation, close
onionFinal.fla.

3
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Open onion.fla from the chap_04
folder.

This file contains one keyframe with the
snowboarder beginning his jump on the
top layer and one keyframe with the
snow on the bottom layer. The snow
layer has been locked so that you don’t
accidentally select something on it. 
You will be modifying the artwork and
creating the frame-by-frame animation
on the snowboarder layer in the next
few steps.

Click Frame 2 of the snowboarder layer to select it, and choose Insert > Timeline > Keyframe to
add a keyframe.

Frame 2 now contains a small black dot, indicating it contains content. As you know from Exercise 2,
when you create a new keyframe, it copies the content from the previous keyframe—in this case, Frame 1.

Tip: If you try to add a keyframe without first selecting a frame, nothing happens. Why? When you have
more than one layer in your document, you have to select the frame so Flash CS3 knows in which layer to
insert the keyframe.

With the playhead on Frame 2,
click the snowboarder artwork on the
Stage to select it. You’ll know it’s
selected when you see the dotted
mesh. Drag the snowboarder up and to
the right, as though he were advancing
in his jump.
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Click the Onion Skin button.

Notice the faint ghost image show-
ing the content of Frame 1 on the
Stage. Onion skinning lets you see
the artwork in the previous keyframes
and change the artwork relative to
the ghost images.

7
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Frame 2 content

Frame 1 content

N O T E : Onion Skin Markers
After you click the Onion Skin but-
ton, a gray bar with a draggable
bracket on each end appears at
the top of the Timeline. These are
called onion skin markers. The
start onion skin marker (the one 
on the left) is on Frame 1 (the first
frame of your animation), and the end onion skin marker (the one on the right) is on
Frame 5 (the last frame of your animation). If you click and drag your playhead to the
right or left, the start onion skin marker will move along with it. You can also drag
either of the onion skin markers to the left or right to include more frames if they are
spanning fewer keyframes than you have on the Timeline.

Onion skin markers

Onion Skin button

Select the Free Transform tool in the Tools panel.

The Free Transform tool lets you modify selected artwork by changing the
size, rotation, skew, and distortion. To learn more about the Free Transform
tool, check out the chart at the end of this exercise.

8
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Make sure the playhead is on Frame 2, and click the snowboarder on the Stage to select it.

Notice a bounding box appears around the artwork, indicating you can transform the artwork. If you
position the cursor near or over the handles (the squares in the corners and on the edges of the bound-
ing box), the cursor changes, indicating the transform options.

Position your cursor just outside the upper-right corner of the
bounding box until it changes to the rotate icon (a round arrow). 
Click and drag to the right to rotate the snowboarder slightly to 
make the jump look more realistic.

Click Frame 3 to select it, and choose Insert > Timeline > Keyframe to insert another keyframe.

Click the snowboarder artwork
with the Free Transform tool to
select it. Click and drag the snow-
boarder to the right. Using the tech-
nique you learned in Step 9, click
and drag to rotate the snowboarder.
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Repeat Steps 11 and 12 twice, adding keyframes to
Frame 4 and Frame 5 and positioning and rotating the
artwork in each keyframe. When you’re finished, the 
artwork on the Stage should match the artwork shown 
in the illustration here.

Choose Control > Loop
Playback. Press Enter
(Windows) or Return (Mac) 
to preview the movie on the
Stage. When you’re finished,
choose Control > Loop 
Playback to stop the movie 
from repeating, and press 
Enter (Windows) or Return
(Mac) to stop the movie.

As you can see, the snowboarder is catching some air—just like in the final movie you looked at in Step 1!

If you do not want the onion skin markers to move when you move the playhead or click a frame on the
Timeline, you can choose Anchor Onion in the Modify Onion Markers button pop-up menu to lock the
onion skinning span where it is until you unlock it again or manually drag the start or end onion skin marker.

Experiment with the Free Transform tool to create more effects. Try resizing, rotating, and skewing
using the editing nodes.

You’ll get a chance to work with the Free Transform tool again in Chapter 6, “Creating Symbols and
Instances.”

When you are finished experimenting, close onion.fla. You don’t need to save your changes.16
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Modify Onion Skin markers

V I D E O : onion.mov
To learn more about onion skinning, check out onion.mov in the videos folder 
on the Flash HOT CD-ROM.
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N O T E : The Free Transform Tool
The Free Transform tool lets you modify objects in several ways. As you position the
cursor over the bounding box of a selected object, it will change to indicate what
type of transformation is available. As you click and drag, you will see a preview of the
transformation you are about to make. The following chart lists how you can use the
Free Transform tool to transform objects:

Free Transform Tool Features

Example Description

Clicking and dragging up or down on a corner trans-
form handle rotates the object. The cursor icon changes
to a round arrow, indicating you can rotate the object.

Clicking and dragging one of the corner transform 
handles diagonally modifies the scale of the object. 
The cursor changes to a diagonal double-pointed 
arrow when you can perform this transformation.

Clicking and dragging one of the middle-side transform
handles modifies the width or height of the object. The
cursor changes to a horizontal (or vertical depending on
which side you are on) double-pointed arrow when you
can perform this transformation.

Clicking and dragging between any two transform han-
dles skews the object. The cursor changes, indicating
you can skew the object.

Clicking and dragging one of the middle-side transform
handles to the other side of the object flips the object.
The cursor changes to a horizontal or vertical double-
pointed arrow depending on which side you are on.

Clicking and dragging the center registration point
modifies the center point of the object. After you alter
the center point, all transformations will rotate or move
in relation to the new center point location.
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6
E X E R C I S E

Testing Movies

So far, you’ve been testing your movies by previewing them on the Stage. This is a great way to test the
frame rate, but you can test your work in other ways. In this exercise, you will learn how to preview the
movie file as a SWF file—the format you would use to publish the movie to the Web—with the Test
Movie feature. You’ll learn a really easy way to produce the HTML file required to view the SWF file in a
browser. You’ll also learn how to preview the movie in a browser with the Preview in Browser feature.
This exercises covers the basics—you’ll find more in-depth information about publishing Flash CS3 
content in Chapter 17, “Publishing and Exporting.”

Open frames_Test.fla from the
chap_04 folder.

It is important to know where your
project file (FLA) has been saved
before you use the Test Movie and
Preview in Browser features because
Flash CS3 generates new files and
automatically saves them in the same
location as your project file (FLA). If
you saved your file in a different loca-
tion, just make sure you know where 
it is. In this case, you’re working with 
frames_Test.fla, which is included in 
the chap_04 folder.

Choose Control > Test Movie 
or press Ctrl+Enter (Windows) or
Cmd+Return (Mac) to preview 
the movie file in a new window 
as a SWF file.

When you test the movie, Flash CS3 
automatically previews the movie as 
a SWF file, which is exactly what you’d 
see if you exported the file as a SWF.

Tip: You can click and drag the resize handle of the preview window to change its size. Although the size
of the window changes, the snowboard letters stay the same size. You’ll learn how to make content scala-
ble using the publish settings in Chapter 17, “Publishing and Exporting.”

2

1

92 Adobe Flash CS3 Professional : H•O•T

Resize handle

04_FlashCS3HOT_(66-95).qxd  08/08/2007  01:21 PM  Page 92



With the preview window still
open, choose Window > Toolbars >
Controller to open the Controller
toolbar.

This handy little gadget is especially
useful with longer movies—it lets
you easily stop, restart, or step back
one frame at a time on the Timeline.

Click the Stop button on the Controller to stop your animation.

Click the Play button to play the animation. If you’d like, experiment with the other buttons 
on the Controller.

Although you didn’t see it happen, when you tested the movie in Step 2, Flash CS3 automatically 
created the SWF for the movie and saved it in the same location as your project (FLA) file. You’ll 
locate this file next.

Open the chap_04 folder.

Notice the frames_Test.swf file inside this
folder. Flash CS3 automatically generated this
file. Also notice the SWF file has a different
icon than the FLA files, which can be helpful
visual feedback, especially if your file exten-
sions are turned off. The SWF file is the file
you’d use on a Web page in the same manner
you would use a GIF or JPEG.
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T I P : Loop-de-Loop
At this point, you’re probably wondering why your animation is looping (playing over
and over). This is the default behavior of all movies in Flash CS3, although you don’t
see it when you simply press Enter (Windows) or Return (Mac) to preview your movie
(unless you’ve turned on the Loop Playback option). If you uploaded this published
file to the Web, it would loop. You will learn to control the looping in your final movie
(SWF) file in Chapter 12, “ActionScript Basics,” when you learn how to add actions to
frames. But if all this looping is making you dizzy, you can choose Control > Loop to
turn this feature off in the SWF preview window.

Stop

Rewind Play

Step Back Step Forward

Go to End
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Return to Flash CS3, and close the preview window.

Choose File > Publish
Preview > Default – (HTML) or
press F12 to launch your default
browser with a preview of your
movie file (SWF).

Previewing the SWF file in a
browser is a quick and easy way to
see what the movie looks like and
how it plays back in a browser.
Although this technique is great for 
previewing your movies, you’ll learn 
better ways to publish the final 
SWF file in Chapter 17, “Publishing 
and Exporting.”
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N O T E : Defining a Default Browser
If you have several browsers installed on your computer, you can specify which one
Flash uses as the default browser. You can find a great explanation of how to define
default browsers in Windows and on a Mac on Adobe’s Web site:

www.adobe.com/cfusion/knowledgebase/index.cfm?id=tn_15133

Hide Flash CS3, and navigate to
the chap_04 folder.

Notice there is a frames_Test.html file
inside the chap_04 folder. When you
published a preview of the file in Step
8, Flash CS3 generated the HTML file
automatically, which is what lets you
view the SWF file in a browser.

At this point, all the files necessary to
publish to the Web have been gener-
ated for you automatically. You’ll find
more thorough instructions and details
about this process in Chapter 17,
“Publishing and Exporting.” The 
purpose of this exercise was to
demonstrate a quick and easy way 
to preview your projects.

9
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Return to Flash CS3. Close frames_Test.fla. You don’t need to save your changes.

Congratulations—you just completed a long but essential part of your animation training! The next three
chapters focus on more complex and specific animation topics, such as shape tweening, symbols and
instances, and motion tweening. Now would be a great time for a break. You’ve worked through a lot of
material, and you deserve one!

10
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