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Photoshop CS and ImageReady CS offer great
tools for working with color. In this chapter,

you’ll learn useful tips for picking, editing,
and changing colors. You’ll explore the

Color Picker and Swatches palette, then
recolor images with the colors you
choose. You’ll also learn how to
recolor images using the new Color
Replacement tool in Photoshop CS.

You’ll find less emphasis on Web-
safe color in this chapter than you
may have come to expect in our
lynda.com series of books. Today,
there’s less reason to use to a
browser-safe palette, because 8-bit

(256-color) computer display systems
are practically obsolete. You’ll read

about the decline of Web-safe color in
this chapter, but you’ll also discover how

to access Web-safe colors when you need
them. Along the way, you’ll determine how to

limit the Color Picker dialog box to Web-safe 
colors, load a special lynda.com swatch of Web-

safe colors, create your own custom color swatches,
and copy color values to HTML.
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Color Profiles and the Web
Have you ever looked at the same image on two computers and noticed that the colors look different? This
very common problem can be caused because there is no calibration standard for screen-based colors.

In the print world, designers use ICC (International Color Consortium) profiles to make sure the colors
onscreen look the same when they’re printed. ICC profiles are embedded into the image file format
and provide additional information about the color characteristics of the image. This color information
stays with the file so any device can display or print the file accurately.

Unfortunately, you cannot use ICC profiles when designing Web graphics. First, embedding ICC 
profiles increases the image size, which negatively impacts how quickly graphics load. In some cases,
a color profile can be upwards of 750 KB, which may be larger than an optimized Web graphic.
Second, Web browsers can’t read color profiles. As a result, any efforts you make to keep colors 
consistent using ICC profiles will be lost as soon as your graphics hit the Web.

sRGB for Windows
In an effort to standardize how colors are displayed onscreen, Microsoft and Hewlett-Packard 
developed a new color space called sRGB. The goal of sRGB is to produce a reliable and repeatable
method for describing color that can be understood by computer monitors and that picks up one 
calibration based on an average monitor.

In Photoshop CS, the color settings are set to use sRGB by default. Therefore, you can begin creating
Web graphics on Windows without making any changes. Unfortunately, this is not true if you’re using a
Mac. At the moment, sRGB is a color workspace that is supported natively on Windows systems, and
only in certain applications like Photoshop CS on the Mac. If you are on a Mac, please read the follow-
ing sections that relate to your system.

Photoshop CS/ImageReady CS for the Web H•O•T | 3.Color

NOTE | What Is Gamma?

sRGB calls for a standard gamma setting of 2.2. What is gamma, you might ask? The gamma
affects the appearance of your computer screen, as it defines a midpoint for gray, meaning that it
affects the grays or values between white and black, not the white-point or black-point display.
Windows computers ship with a 2.2 gamma setting; Macs use a 1.8 gamma setting. As a result,
Web graphics look darker on Windows than they do on Macs. In Photoshop CS and ImageReady
CS, there are ways to preview the gamma of a graphic on either platform. Open any graphic
inside either program. To preview gamma in Photoshop CS, choose View > Proof Setup and
select either Windows RGB or Macintosh RGB. To preview gamma in ImageReady CS, choose
View > Preview and select either Standard Macintosh Color or Standard Windows Color.
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sRGB and Gamma for Macs
If you’re using a Mac, you need to consider a few things with respect to color settings before you
begin designing Web graphics.

By default, the Photoshop CS color settings are set to Web Graphics Defaults, which uses sRGB and
a gamma of 2.2 as its default color setting. On a Mac, this is can be a problem because colors will be
different in Photoshop CS than in most other Mac applications, including ImageReady CS (!) and
Microsoft Internet Explorer, Safari, and Netscape browsers that don’t currently support sRGB! This can
be extremely frustrating when you’re designing Web graphics on a Mac because your colors will con-
sistently look different, depending on which application you use.

The color workflow is different for Web graphics than it is for print graphics. The great thing about
Photoshop CS is that you can change your color settings at any time. This makes it possible to use
one color setting for Web color workflow, and another for print color workflow. You’ll learn how to
change your color settings in Photoshop CS in the sidebar that follows this section.

If you’re using a Mac, you can choose to keep the Photoshop CS default color settings so they use
sRGB; just be aware your images will appear differently in other applications, including ImageReady
CS. If you would prefer that your images look the same in all applications with a 1.8 gamma setting,
you can turn off the color settings by following the instructions below.

3.Color | Photoshop CS/ImageReady CS for the Web H•O•T
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NOTE | Changing Photoshop CS Color Settings

If you’re using a Mac, you may decide to change your Photoshop CS color settings so they no
longer use sRGB, which will ensure the colors you choose in Photoshop CS will look the same in
ImageReady CS, other graphics applications, HTML editors, and Web browsers that don’t use
sRGB. Here’s how.

Launch Photoshop CS, and choose Photoshop > Color Settings.

In the Color Settings dialog box, change the settings to RGB: Adobe RGB (1998) and Gray:
Gray Gamma 1.8. This will cause the menu called Settings to change automatically to Custom.
Click OK.

Note that this change sets the RGB working space to Adobe RGB (1998), which leaves the
appearance of your monitor set to its defaults as in ImageReady CS, other graphics applications.
HTML editors, and Web browsers. The graphics on your screen will appear without any alterations.
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NOTE | Setting Gamma on a Mac

If you’re using a Mac, you may decide to change your gamma settings to 2.2. If you think your site
might have a larger Windows audience, this change may save you from potential unanticipated
revisions to lighten up your graphics. Keep in mind that changing your gamma settings will affect
all applications, not just Photoshop CS.

To change your gamma settings, use the calibration utilities built into Mac OS X. In the Finder,
choose Go > Applications. Double-click on the Utilities folder, then double-click the Display
Calibrator to launch the Display Calibrator Assistant. Click the forward arrow at the bottom-
right corner of the dialog box to navigate to the Select a target gamma screen. Choose 2.2
Television Gamma. Click the forward arrow twice and name your profile Windows Gamma.
Click Create.

Changing your gamma to match Windows is a benefit—it affects all applications, including
Photoshop CS, ImageReady CS, other graphics applications, HTML editors, and Web browsers.
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The Decline of Web-Safe Color
The concept of Web-safe color was introduced when the Web first gained popularity in the mid
1990s. At that time, (back in dark ages!) the majority of computer users owned computers that were
only capable of displaying 256 colors or less. These old computers were called 8-bit color systems,
because they were limited by hardware constraints to display only 256 colors. Most graphics profes-
sionals owned computers that were 24-bit (displayed millions of colors), which at that time cost a lot
more money than the average 8-bit consumer computer. For this reason, if a Web designer had a bet-
ter computer that could display millions of colors, there was a good chance that the better computer
could produce colors that would not be accurately portrayed on the more common 8-bit computers in
circulation back then.

Hence, the Web-safe palette was born, and was first published and described in Lynda Weinman’s
book, Designing Web Graphics (1996). This palette contains only 216 colors. However, the 216 were
special, because these colors could be accurately displayed on the 8-bit computer systems.

The term Web-safe color refers to the use of these special 216 colors. Other terms, such as the Web
palette, 216-color palette, Netscape palette, or 6 x 6 x 6 color cube all refer to the same 216 colors.
You should limit your color choices to only the browser-safe palette if you think your Web site will be
viewed on an 8-bit system. Just a few short years ago, almost all computers had 8-bit video cards.
When Web design first emerged as a design medium, it was important for designers to understand
Web-safe color and how to create Web graphics in this limited palette. This was no picnic, because
the browser-safe palette is not very visually exciting. (It contains mostly highly saturated colors of
medium value and not many light or dark colors, nor many muted or tinted tones.)

Good news: In most cases, it is now safe to design for the Web without the browser-safe palette.
Today, very few computer users have machines with 8-bit video cards and most users can see any
color you design with. If you’re unsure about when to use the Web-safe palette, the answer depends
on your audience, clients, and maybe even the employer for whom you’re designing.

Photoshop CS/ImageReady CS for the Web H•O•T | 3.Color

TIP | Finding Additional Color Management Help

Photoshop CS ships with additional documentation about color management, which is accessible
from the Welcome Screen. The Welcome Screen appears when you launch the application, or
you can open it by choosing Help > Welcome Screen. Keep in mind that color management is a
complex topic and is primarily used for print design. If you’re interested in learning more about
color management, be sure to give the additional documentation a read. You can also find more
information in the Photoshop CS User Guide.

038553_ch03  12.05.03  12:29 PM  Page 69



| 70 |

If you’re designing Web sites for alternative online publishing devices such as cell phones, PDAs, or
Internet appliances, you may still need to use a browser-safe palette. Most of those devices currently
display only 8-bit color, and some are still 1-bit (black-and-white) systems.

Some companies still feel it’s a badge of Web design honor to work with browser-safe colors, so you
might want to know how to use them. As you’ll learn in this chapter, the Web palette is built into color
picking tools in Photoshop CS and ImageReady CS, so it’s easy to create or recolor a Web graphic in
browser-safe colors.

Keep in mind there’s no harm in using the browser-safe palette. It simply limits your choices to 216
colors. If you don’t have a lot of experience or confidence picking colors that work well together, you
might find it easier to work with a limited number of color choices. There’s no right or wrong about
using browser-safe colors as long as you’re able to combine them in pleasing and effective ways.

The upside is that the need to stick to a browser-safe palette is on the decline. It may be difficult to let
go of the notion that you should design with Web-safe colors, particularly if you’ve put effort into devel-
oping that skill. Try to see it as I do—it’s a sign of the great progress that most computers today have
better color displays, and a liberating step forward for Web design!

What Happens on an 8-bit System If You Don’t Use Web-Safe
Colors?
It’s useful to know what your site will look like if you don’t design with Web-safe colors, and your site is
viewed on an 8-bit system. Two problems will occur.

First, the colors you set in the HTML code, such as the colors of page backgrounds, text, and links, will
shift in the 8-bit viewer’s browser. Unpredictable color shifts can cause text or links to be unreadable
against a like-colored background.

Graphic viewed in 24-bit color Same graphic viewed in 8-bit color

3.Color | Photoshop CS/ImageReady CS for the Web H•O•T
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Close-up in 24-bit color Close-up in 8-bit color

The second problem involves color. If you make flat art (such as illustrations or cartoons) with non-
Web-safe colors, these colors will appear dithered (made up of tiny dots) when the image is viewed 
on an 8-bit system. The unwanted dithering is the result of the viewer’s 8-bit display system trying to
simulate colors it can’t display. The previous illustrations demonstrate what that looks like, which shows
why you’ll want to use Web-safe colors in your flat art Web graphics in the rare event you’re designing
for an 8-bit audience. However, the opposite is true for photographic content. If you’re preparing pho-
tographs for the Web, never force them to Web-safe colors. When an 8-bit browser displays photo-
graphic images, it converts them to 8-bit on the fly and does a better job than if you’d converted them
yourself.

In the next few exercises, you’ll learn how to select Web colors when you want them, and how to use
the color picking tools Photoshop CS and ImageReady CS offer. You’ll also learn how to pull it all
together with quick and easy ways to recolor layered artwork.

Photoshop CS/ImageReady CS for the Web H•O•T | 3.Color
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Choosing Web-Safe Colors from the Color Picker

In early versions of Photoshop, it was difficult to choose a Web-safe color from the Color Picker dialog
box without manually typing in Web-safe RGB values. This hassle has been removed since Photoshop
5.5, because the Color Picker dialog box can now be set to display only Web colors.

3.Color | Photoshop CS/ImageReady CS for the Web H•O•T

1.

1. Click on the foreground color in the Photoshop CS Toolbox to open the Color Picker 
dialog box.

[PS]
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2. Check Only Web Colors in the bottom-left corner of the Color Picker dialog box.

Notice the hexadecimal readout at the bottom of the Color Picker dialog box. If you move the arrows
up the vertical hue slider, you’ll see these readout numbers and the colors on the screen change.

H, S, and B stand for Hue, Saturation, and Brightness. The Color Picker dialog box in the previous
screen shot is set to view by hue. All the different radio buttons offer different ways of seeing and
picking colors. You may find these different choices help you more quickly find colors that fit together.
It’s very interesting to see how Web colors spread across the spectrum if you actively move the slider 
when exploring these different settings of H, S, B, R, G, B, or L, a, b.

3. Click S to view the Color Picker by Saturation, which is the measure of color intensity. Try moving
the vertical slider or clicking on a different color in the rainbow area to view Web-safe colors by
Saturation. Move the slider arrows up to view more highly saturated Web colors, and down to view 
the desaturated ones.

Photoshop CS/ImageReady CS for the Web H•O•T | 3.Color

Currently
selected

color

Hue slider

Hexadecimal
color value
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4. Click B to view the Color Picker by Brightness, which is the measure of light to dark values. To
view Web-safe colors by this criterion, try moving the brightness slider or clicking on a different color 
in the rainbow area. Move the slider arrows up to view brighter Web color values, and down to view
darker ones.

Try clicking on the R, G, and B buttons as well. These stand for Red, Green, and Blue. Click on 
the L, a, and b buttons next. These stand for Lightness, a Axis (green to magenta), and b Axis (blue
to yellow). Aside from the psychedelic color experience, these methods offer some interesting color
formations you can use to view or pick Web colors.

In Photoshop CS, there are often numerous ways to achieve the same goal. Instead of viewing only
Web-safe colors, you can view all colors and then snap a non-Web-safe color. This feature is also
available in ImageReady CS.

3.Color | Photoshop CS/ImageReady CS for the Web H•O•T

038553_ch03  12.05.03  12:29 PM  Page 74



| 75 |

5. Uncheck the Only Web Colors box and click on the H button to display the Hues view. Move and
click your cursor around inside the color area on the left. Notice the cube icon that appears to the right
of the color preview. The cube alerts you when you’ve selected a non-safe Web color. Click on the
swatch below the cube. The color selection will jump to the closest Web-safe color, and the cube will
disappear.

6. Click OK, and the Web-safe color you just chose will appear as the foreground color in the
Toolbox.

Note: This feature works identically in ImageReady CS. If you decide to try it out in ImageReady CS
now, be sure to return to Photoshop CS for the next exercise.

Photoshop CS/ImageReady CS for the Web H•O•T | 3.Color

NOTE | ImageReady CS and Photoshop CS Color Picker Differences

ImageReady CS has a Color Picker dialog box almost identical to the Photoshop CS Color
Picker dialog box. The Color Picker dialog box in ImageReady CS lacks some print-oriented fea-
tures, such as feedback about L.a.b. and CMYK color and out-of-print gamut warnings. That’s
because Photoshop CS can be used to design for print or the Web; ImageReady CS was devel-
oped specifically for designing Web graphics.
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TIP | Choosing Web-Safe Colors from the Color Palette

In addition to choosing Web-safe colors from the Color Picker dialog box, you can also choose
Web-safe colors from the Color palette in Photoshop CS and ImageReady CS. You may find it
easier to choose colors from the Color palette because you can leave it open at all times instead
of reopening and closing the Color Picker dialog box. To choose Web-safe colors from the Color
palette, first make sure the Color palette is visible. If it is not, choose Window > Colors.

Choose Web Color Sliders from the Color palette menu.

When you use the Web color sliders, the colors will automatically snap to Web-safe colors at the
tick marks. If you want to override the Web color sliders, hold down the Option key (Mac) or Alt
key (Windows). As soon as you choose a color that is out of the Web-safe color range, the alert
cube will appear to the left of the sliders. You can choose the closest Web-safe color by clicking
the swatch below the cube, just as you did using the Color Picker dialog box.

Note: In Photoshop CS, you must choose Web-safe colors to view the alert cube. Because
ImageReady CS is designed specifically for creating Web graphics, the alert cube is available 
for all sliders.
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1. Make sure the Swatches palette is visible. If it is not, choose Window > Swatches.

2. Choose Web Spectrum from the Swatches palette menu.

3. Click OK to replace the current swatches with the Web Spectrum swatches.
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Loading Color Swatches

Another way to choose colors in Photoshop CS and ImageReady CS is to use the Swatches palette.
Photoshop CS and ImageReady CS ship with a number of prebuilt swatches, including swatches cre-
ated specifically for designing Web graphics. In addition, you can load swatches created and saved by
other Photoshop CS and ImageReady CS users. Here is an exercise to show you how. This exercise
takes place in Photoshop CS, but works the same way in ImageReady CS.

Photoshop CS/ImageReady CS for the Web H•O•T | 3.Color

2. [PS]
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The Swatches palette will now be updated with the Web Spectrum swatches. Increase the size of
the Swatches palette so it displays all the colors by dragging the resize handle in the bottom-right
corner of the palette. You can choose any color in the Swatches palette by clicking it. Note that 
when you click on a color in the Swatches palette to choose it, the foreground color in the Toolbox
automatically changes to reflect your choice.

Next, you’ll learn how to load the lynda.com swatch that is included on the H•O•T CD-ROM.

Lynda Weinman and Bruce Heavin wrote a book together in 1997 called Coloring Web Graphics,
which is now out of print. Bruce developed a series of Web swatches for that book, which he 
organized aesthetically to make it easier to choose Web-safe colors. One of these swatches is
included inside the chap_03 folder of the H•O•T CD-ROM for you to load and use.

3.Color | Photoshop CS/ImageReady CS for the Web H•O•T
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4. Choose Replace Swatches from the Swatches palette menu.

5. Navigate to the chap_03 folder you copied to your Desktop from the H•O•T CD-ROM and choose
color.aco. Click Load (or Open in ImageReady CS).

Note: If you choose Replace Swatches, you will replace the current swatch with the swatch you are
loading. If you choose Load Swatches, you will append the current swatch with the colors of the
swatch you are loading.

Photoshop CS/ImageReady CS for the Web H•O•T | 3.Color
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6. Drag the Swatches palette window down as far as it will go by using the resize handle in the bot-
tom-right corner of the palette. Then, use the scroll bar to view the entire swatch. This swatch is organ-
ized by hue (up and down), by value (right to left), and saturation (up and down).

Note: Many of the colors are repeated to present an array efficiently organized for color picking. It’s
nice to see all the hues together. If you want to pick a red, for example, you can view the choices
easily. It’s also helpful to see all the dark colors and/or colors of equal saturation together. Once you
use this swatch set, you will likely never remove it from the Swatches palette because it is so useful.

7. Choose Reset Swatches from the Swatches palette menu. Click OK to replace the lynda.com
swatch with the default swatch.

3.Color | Photoshop CS/ImageReady CS for the Web H•O•T
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1. Choose Edit > Preset Manager. In the Preset Manager window, choose Swatches from the
Preset Type pop-up menu.

The Preset Manager in Photoshop CS lets you control content libraries, such as swatches, as
well as other application presets such as brushes, gradients, styles, and patterns. In this exer-
cise, you’ll only learn about swatches. For more information about customizing other content
libraries, refer to the Photoshop CS User Guide.
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Creating Custom Swatches

There are going to be times when you have a custom color scheme and you’d rather limit the
Swatches palette to contain only those colors. In this exercise, you’ll learn to make custom swatches
for the Swatches palette two ways—by selecting colors from an existing swatch, and by sampling 
colors from an image. For this exercise, you’ll work in the Preset Manager in Photoshop CS, which is
specifically designed to create custom swatches and other application presets. You can also make a
custom swatch in ImageReady CS, but it’s more tedious because you have work directly in the
Swatches palette.

Photoshop CS/ImageReady CS for the Web H•O•T | 3.Color

3. [PS]

038553_ch03  12.05.03  12:29 PM  Page 81



| 82 |

2. Choose Web Hues from the Preset Manager menu. Click OK to replace the current swatch with
the Web Hues swatch.

This will replace the currently loaded swatch in the Preset Manager (and in the Swatches palette)
with a swatch that contains all the Web-safe colors. The Web Hues swatch is one of a number of
prebuilt swatches that ship with Photoshop CS.

3. Select a few red and orange colors in the Web Hues palette by holding down the Shift key and
clicking on the colors you want to choose. Click Save Set.

3.Color | Photoshop CS/ImageReady CS for the Web H•O•T
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4. In the Save dialog box, type the name Warm Web Colors.aco in the Save As field. Be sure to
include the .aco extension because it will identify the file as a swatch. In the Where pop-up menu, 
navigate to the Color Swatches folder in the Presets folder in the Photoshop CS application folder.
Click Save.

5. In the Preset Manager, click Done.

6. Close and then relaunch Photoshop CS.

You have to close and reopen Photoshop CS in order to see the new swatch listed in the Swatches
palette menu.

Photoshop CS/ImageReady CS for the Web H•O•T | 3.Color
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7. Choose Warm Web Colors from the Swatches palette pop-up menu. You’ll see that your custom
swatch has been added to the list of swatch presets.

8. Click OK to replace the current swatch with the Warm Web Colors swatch, which will now open up
in the Swatches palette.

Next, you’ll make a custom swatch from the colors in an existing image. This is a good way to build a
collection of pleasing palettes for use in your own images.

3.Color | Photoshop CS/ImageReady CS for the Web H•O•T
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9. Open the french.psd file from the chap_03 folder you copied to your Desktop.

10. Choose Preset Manager from the Swatches palette menu.

The Preset Manager opens with your Warm Web Colors swatch showing.

11. Click Cmd+A (Mac) or Ctrl+A (Windows) to select all the colors in the Warm Web Colors swatch
in the Preset Manager. Click Delete to delete all of these colors.

Photoshop CS/ImageReady CS for the Web H•O•T | 3.Color
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12. Click Done to close the Preset Manager.

The loaded swatch now displays no colors, leaving you free to create a custom swatch from scratch.

13. Select the Eyedropper tool in the Toolbox.

3.Color | Photoshop CS/ImageReady CS for the Web H•O•T
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14. Click on a color in the open image with the Eyedropper tool, then click the New Color button at
the bottom of the Swatches palette.

This will add the color you selected in the image to your custom swatch. Repeat this step until you
have all the colors you want in your swatch.

Photoshop CS/ImageReady CS for the Web H•O•T | 3.Color
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15. Choose Save Swatches from the Swatches palette menu.

16. Navigate to the Color Swatches folder in the Presets folder in the Photoshop CS application
folder, name your new swatch French Blue.aco, and click Save.

The next time you launch Photoshop CS, your custom French Blue swatch will appear in the list of
swatches in the Swatches palette menu. You can load that custom swatch and use it to build a new
image or recolor an existing image.

17. Close the image without saving.

3.Color | Photoshop CS/ImageReady CS for the Web H•O•T
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1. Open the lynda.com swatch by choosing Replace Swatch from the Swatches palette 
pop-up menu. Navigate to the chap_03 folder you copied to your Desktop and choose
color.aco. Click Load.

2. Open recolor.psd from the chap_03 folder you copied to your Desktop. Make sure the
Layers palette is visible; if it is not, choose.

Look at the Layers palette (Window > Layers), and you’ll notice this document is composed of
multiple layers. It’s helpful to set up your files with separate layers like this and give the layers
meaningful names so you can color each layer separately and keep track of it.

3. Click the background color layer at the bottom of the Layers palette to select it.

Right now, this image is colored using blues and greens. To change the color scheme to reds
and yellows (or any other color choices you’d prefer), you’ll be working with one layer at a
time, starting with the background color layer.

4. Choose a dark red color from the Swatches palette.

| 89 |

Recoloring Layered Images

Now that you’ve learned how to view and pick colors in a variety of different ways, how do you make
images using those colors? You could brush or paint with any color at any time. You could also use fill
tools. This next exercise focuses on how to recolor an existing Photoshop CS image. It gives you a
chance to work with the Lock Transparent Pixels feature, which allows you to easily recolor layered
images with any color. Our demonstration takes place in Photoshop CS but will work in a similar fash-
ion in ImageReady CS.

Photoshop CS/ImageReady CS for the Web H•O•T | 3.Color

4. [PS]
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5. To fill the background color layer with the dark red color you chose, press Option+Delete (Mac),
or Alt+Backspace or Alt+Delete (Windows).

This is one of my favorite shortcuts for filling a layer with a color, because it is faster than using the
menu command, Edit > Fill, or the Paint Bucket tool.

6. Next, select the circle logo layer that contains the circle. Pick a dark yellow color from the
Swatches palette, and use the fill shortcut again by pressing Option+Delete (Mac), or
Alt+Backspace or Alt+Delete (Windows).

Notice that the entire layer is now filled with this color. In order to recolor the circle, and not the
entire contents of the layer, there’s a valuable trick you’ll learn in the following steps.

3.Color | Photoshop CS/ImageReady CS for the Web H•O•T
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7. Undo the fill you just created by using the shortcut key, Cmd+Z (Mac) or Ctrl+Z (Windows).

8. Click the Lock Transparent Pixels button on the Layers palette, and press Option+Delete (Mac),
or Alt+Backspace or Alt+Delete (Windows). This time, only the contents of the selected layer fill with
yellow.

Tip: The shortcut key to toggle Lock Transparent Pixels on or off is the / (forward slash) key.

Lock Transparent Pixels means that Photoshop CS will protect the transparent areas of this layer.
When you fill the layer with a new color, Photoshop CS fills only the area of the layer that contains
an image and preserves the transparent areas. I can’t tell you how many students I’ve watched try 
to use the Magic Wand tool or other selection tools to select shapes on layers in order to fill them.
The technique you learned here works much better because it’s easier, it fills only areas of the layer
that contain pixel information, and it doesn’t leave rough edges on color fills.
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9. Next, select the editable type layer (signified by the letter T on the layer). Choose an orange color
from the Swatches palette, and press Option+Delete (Mac), or Alt+Backspace or Alt+Delete
(Windows).

Note that the Lock Transparent Pixels button is active, even though it’s dimmed out. This is the
default behavior for an editable type layer.

10. Select the Type tool from the Toolbox. Highlight the words coffee & tea in the type layer by 
clicking and dragging over them.
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11. Choose a bright red color from the Swatches palette, and press Option+Delete (Mac), or
Alt+Backspace or Alt+Delete (Windows). After you deselect the type by clicking on a different layer,
you’ll see that only the words coffee & tea on the type layer changed color.

12. Select the smoke curl layer. Choose white from the Swatches palette. Click the Lock
Transparent Pixels button and use the shortcut keys, Option+Delete (Mac), or Alt+Backspace or
Alt+Delete (Windows) to fill with the new color.

What’s really cool about this step is the smoke curl on this layer is slightly blurry. Turning on Lock
Transparent Pixels is the only way to make a clean selection of a blurry graphic.
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13. Select the cup layer. Click the Lock Transparent Pixels button and use the shortcut keys,
Option+Delete (Mac), or Alt+Backspace or Alt+Delete (Windows) to fill with white.

Now all the layers in your image should be recolored from shades of blue and green to shades of 
red and yellow.

14. Close the file without saving.

The skills covered in this exercise will help you recolor layered images as you design Web graphics
or any other graphics in Photoshop CS. You’ll probably use this technique more than most others in
the book.
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Using the Color Replacement Tool

Filling layered images with colors as you did in the last exercise is a great technique if your layers con-
tain only fairly flat colors. If your images have photographic elements, or elements with shaded, tex-
tured, or transparent areas, filling with a solid color won’t give you the effect you’re looking for.

For example, if you’re designing a rollover that is photographic in nature or has a lot of texture and
shading, and you want to alter the color of the rollover for the Over or Down state, you could recolor
the entire image, or a portion of the image, using the Color Replacement tool.

The Color Replacement tool samples the colors in the original image and replaces them with the fore-
ground color while maintaining the texture and shading of the original image. The Color Replacement
tool behaves like a brush in that you brush over the areas of the image or layer you wish to recolor.

Here is an exercise to show you how to use the Color Replacement tool in Photoshop CS.
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1. In Photoshop CS, open poster.psd from the chap_03 folder you copied to your Desktop.

This image is composed of several layers with flat colors, as well as one layer with a photo-
graphic object—the mug. The mug, shadow, and background of the left side of the image are
made up of yellows, beiges, and browns. You’re going to alter the colors of the mug (including
the shadow) and background to match the shades of blue in the right side of the image.
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2. In the Layers palette, click the mug layer to select it.

3. Select the Eyedropper tool in the Toolbox and click in the blue background of the image to
change the foreground color.

3.Color | Photoshop CS/ImageReady CS for the Web H•O•T

038553_ch03  12.05.03  12:29 PM  Page 96



| 97 |

4. Select the Color Replacement tool from the Healing Brush fly-out menu by clicking the arrow on
the bottom-right corner of the Healing Brush tool.

5. Brush over the entire coffee mug, including the shadow to the bottom right of the mug, with the
Color Replacement tool. If you want to change the size of your brush, use the [ key to decrease 
and the ] key to increase the brush size.

The mug is now shades of blue. Notice that the original tones, shades, highlights, and textures of the
coffee mug image have been maintained. Very cool!

Next you’re going to recolor the yellow background to match the blue you used for the coffee mug.
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6. In the Layers palette, click the yellow layer to select it.

7. Keep the same foreground color you chose in Step 3. Now, begin brushing over the yellow back-
ground with the Color Replacement tool.

You’ll notice that even though you chose a darker color as the foreground color, the Color
Replacement tool identifies that the yellow background is lighter and it applies the blue with the
same level of intensity. This is an easy way to recolor graphics with multiple colors based in a com-
pletely different color scheme because it preserves the shade and intensity of the original colors.
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Alternatively, if you want to recolor the poster.psd image to match the yellows and beiges on the left
side of the image, you can easily do that by sampling the yellow from the background and using the
Color Replacement tool to brush over each of the layers made up of different shades of blue.
Using this technique is an easy way to match colors to a new color scheme without having to go
through the hassle of choosing new colors that look good together and matching the shading and
intensity of the original colors.

Note: The Color Replacement tool permanently changes the colors in your image. If you wish to
make nondestructive changes and preserve the original image, you may want to use the
Hue/Saturation Adjustment Layers, which will be covered in Chapter 5, “Layers.”
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TIP | Using a Wacom Tablet

If you find you’re frequently using the Color Replacement tool or any of the other brush tools in
Photoshop CS or ImageReady CS, you may want to consider using a Wacom tablet. It gives you
the feeling you’re painting with a real brush instead of a bar of soap, like when you’re using a
mouse.

If you create graphics using a computer, a pen tablet will make your workflow faster and easier.
You can go from light to dark, thin to thick, or opaque to transparent using the pressure sensitivity
of a Wacom tablet. For more information about Wacom tablets, visit Wacom’s Web site at
www.wacom.com.
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1. In Photoshop CS, open french.psd from the chap_03 folder you copied to your Desktop.

2. Select the Eyedropper tool from the Toolbox, then click on a color in the background of 
the image.
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Copying Color as HTML

This exercise will be of value to you if you’re used to programming your own HTML code or working
with an HTML editor. If you don’t work with HTML, feel free to skip this one!

If you’re making an image in Photoshop CS or ImageReady CS and want to capture a color from that
image to place inside your HTML code so you can color a background, link, or other element in HTML
to match the image, you can use the Copy Color as HTML feature.

When you specify color in HTML code, as you must for elements like background color, text, and links,
you must use values from a different numbering system called the hexadecimal system. In a nutshell,
the hexadecimal numbering system is based on 16 digits and uses letters as well as numbers to iden-
tify colors. You don’t have to worry about knowing any more than that when you’re working with
Photoshop CS and ImageReady CS. They take care of the math for you.

The Copy Color as HTML feature converts any RGB (red, green, blue) color value (for example, the
shade of blue in this example is called 153 153 204 in RGB parlance) to a string of hexadecimal 
digits (#9999CC in this example). This command also puts the hexadecimal color value into your 
computer’s clipboard so you can paste it as text into other applications—a handy feature if you’re 
writing HTML from scratch and want to place a color value into your code quickly and easily.
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3. Ctrl+click (Mac) or right-click (Windows) on a color in a document, and choose Copy Color as
HTML from the contextual menu.

If you’re working in ImageReady CS, first click on a color in the document with the Eyedropper tool,
then Ctrl+click (Mac) or right-click (Windows) anywhere in the document and choose Copy
Foreground Color as HTML.

Note: The Eyedropper tool must be selected for this to work in Photoshop CS or ImageReady CS.
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4. Open a text editor or HTML editor and choose Edit > Paste or press Cmd+V (Mac) or Ctrl+V
(Windows). When you paste the color into a text editor or HTML program, it will look like this:
COLOR=”#9999CC”.

5. Close both files without saving.

Now you know how to use the flexible color-picking features in Photoshop CS and ImageReady CS
and how to apply your color choices quickly and efficiently to a layered image. These programs make
choosing and using color fun and creative by offering the best color-picking tools around.

In the next chapter, “Optimization,” you’ll learn how to optimize and save Web graphics.
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